PPS Supplier issue - high error rate (initial)

Incident Report for Priceline Partner Solutions

Resolved

The supplier's performance has returned to normal operational levels, and this incident is now considered resolved.
Posted Apr 24, 2025 - 12:37 CDT

Update

The supplier has resolved the issue on their end. We have re-enabled the connection and are closely monitoring their performance to ensure stability.

Re-enabled time - 11:53 AM CDT
Posted Apr 24, 2025 - 11:56 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2025 - 11:55 CDT

Investigating

We are currently observing elevated error rates with a mid sized supplier during availability searches. This may lead to longer-than-expected search times or limited inventory visibility. Our team is actively investigating the matter to identify and implement a resolution.
Posted Apr 24, 2025 - 10:27 CDT
This incident affected: Getaroom Stays (Search (Single/MultiProperty)) and PPS One Stays (GraphQL Availability (availablePropertiesByID), GraphQL Pre-book (stayItineraryPreview), gRPC Book).