PPS Supplier booking failure

Incident Report for Priceline Partner Solutions

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 09:30 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2026 - 09:23 CDT

Identified

We have identified the root cause of the issue and are actively implementing a resolution to address it promptly. Partners may expect a temporary reduction in booking success rates or availability during this period as the fix is deployed.
Posted Jul 14, 2026 - 08:18 CDT

Investigating

We are currently observing an unexpected increase in booking failures at this time and are actively investigating the underlying cause.
Posted Jul 14, 2026 - 08:04 CDT
This incident affected: PPN Stays (Search (Express.Availability/Results/MultiContract)), Getaroom Stays (Search (Single/MultiProperty)), and GraphQL Availability (availablePropertiesByID).