PPS Supplier booking failure (Identified)

Incident Report for Priceline Partner Solutions

Resolved

The supplier issue causing the reduction in availability has been fully resolved. All search and availability services are operating normally. Thank you for your patience.
Posted Sep 22, 2026 - 02:21 CDT

Monitoring

A fix has been deployed by the supplier, and availability metrics are returning to normal levels. We are currently monitoring the system to ensure stability.
Posted Sep 22, 2026 - 02:17 CDT

Identified

We have identified the root cause of the issue and are actively implementing a resolution to address it promptly. Partners may expect a temporary reduction in booking success rates or availability during this period as the fix is deployed.
Posted Sep 22, 2026 - 01:30 CDT
This incident affected: PPN Stays (Search (Express.Availability/Results/MultiContract)) and Getaroom Stays (Search (Single/MultiProperty)).